3 Column K2 0.9.3

I finished my exams yesterday and today here I am finishing an update for 3 Column K2. Its based on SVN-225 and as Andrew mentioned in the comments, it includes a solution to the Sidebar Modules problem most people are experiencing ( I am not able to reproduce this problem from my side so far ). It also has lot of changes all over since the last release (SVN-198), so I recommend everyone using 3 Column K2 0.9.2 to update to this version. You can get the latest release from the 3 Column K2 page which can be accessed from the menu in the header. Thanx everyone for patiently waiting on this release. Njoy.

And regarding long silence here, I am sorry for the lack of posts and updates in the past 2 months. I was bizy with my other work and I hope to post and release updates more frequently from now on.

  1. Hello Bharath !
    Thank a lot for your 3 column K2 tuning – I just wanted to make same thing – and here is your theme.

    Thank again and have a good day.

    If I can somehow helpsupport you – just let me know ๐Ÿ˜‰

    Bye

  2. What plugin do you use for taging your post? I see you have both categories and tag on site. What plugin can make this possible?

    Thanks for answer!

  3. Slava: I am using Christine’s Ultimate Tag Warrior for tags.

    Thanx to everyone else for using this new release.

    But there is still one more bug for IE7 and I am trying to fix it. Any one using IE 6, can you please lemme know how it looks in IE 6. Thanx again.

  4. I have a problem… if I try to add a new module it says “You must specify a valid module name”. Help pls…

  5. Derek: I am updating the style I am currently using to latest svn release and I will release it before weekend.

    Zuperman: Have u given valid module name?

  6. I think yes but pls tell how it is correct ? maybe i’m not doing it right… Thx

  7. Zuperman: I tried on the original K2 and I still having the same problem as you. I will file a bug report and will let you know.

  8. @ Bharath & Zuperman

    me having the same problem as well. wats the remedy?
    and can someone tell me wat a valid module name is? it can be anythin, right? or some special format? help me as i need to get this thing running soon. Thnx!

  9. If i use a widget it gives me the same thing right ? a siderbar widget… ? I’m new so don’t laugh if i’m not right ๐Ÿ™‚

  10. Hi there. Nice blog you have and I think this blog deserves better coverage and link exchange will lead you to it.

    I would like to ask for a link exchange between this blog of yours and mine.

    If you accept my request, kindly add my link to your blog, proceed to my blog and tell me about it.

    Ignore this if you decided to deny my request.

  11. problem still not solved. i tried to look into it myself as well. kindly help!

  12. Hi, I just did the upgrade. I am noticing a bar that says, “loading” and has a line between the words “newer” and “older”. I get this both in Firefox 2.0 and IE7. Also in Firefox I only see my blog post title for the first entry on the page. All other entries have the titles missing.

    You can find it here… http://podcast.revtim.com

    Or actually the direct link is … http://r-hope.com/rhblog

    Thanks, Tim

  13. I am having the header problem, as well. What is more of a mystery is, right below it, between ‘older’ & ‘newer’ there is a slider with a bar that always shows ‘loading’.

    Did I do something wrong? I hope not, because I love this theme!

  14. Zuperman: You can always use wordpress widgets. But if you want K2 sidebar modules you have to disable WordPress widgets.

    Usman: I am sorry for that but thats the latest release and I am not sure if I can change any code to make it work. Frustrating for me too. As I said to zuperman you can still use WordPress widgets for now.

    And I will update as soon as its been solved

  15. I am finding that the K2 Scheme setting doesn’t do anything.

    I can imagine your frustration. ๐Ÿ™‚

  16. Ok finally good news. The module name problem has been fixed. The rolling archives bar which says loading in IE was also fixed.

    Zuperman and Usman d/l the theme again please. I am sorry for releasing with these problems. I just did to update with the latest SVN.

    This update is based on SN-250

    And finally keep posting the bugs.

  17. Hmm… I’ve still got the rolling archives bar in both IE7 and Firefox 2.

    The post title headlines seem to be working now in both.

    Thanks for your very hard work, it’s totally evident!!

  18. Thnx Bharath!
    the sidebar modules are working fine now ๐Ÿ™‚

    but wat bout Ajax commenting? it doesnt seem to be working for me. How to make it work?

  19. Yes ๐Ÿ™‚ Finally ๐Ÿ™‚ Sidebar modules are working but new problems ๐Ÿ™
    In Internet Explorer the right side of the page… menu(categories, about, months etc) are going down ๐Ÿ™

    And also i don’t like how the comment box looks in IE ๐Ÿ™ But this is not so important.

    Thx and waiting again for some answers ๐Ÿ™‚ great work ๐Ÿ˜‰

  20. Guys, when you tell me something is not working, please let me know which browser ur using so that I can check it accordingly.

    RevTim: Uninstall K2 from K2 options and then activate it from presentation tab and see how it goes. Before this update, yes there is a problem with rolling archives in IE but not FF. But now it works fine in both IE 7 and FF 2. Any one else having problems with rolling archives?

    Usman: Ur welcome. I havent noticed problem with ajax commenting but I am going to check it now and will let you know. Are you having problem with ajax commenting in IE or FF.

    Zuperman: Which version of IE are u using. I see no problems with sidebar in IE 7. But I dont have IE6 and I think everyone has upgraded to IE7 already. There are COUPLE of bugs still to fix in IE7 as well which I am working on. If ur using IE6 and dont want to upgrade to IE7 please mail me and I will try to help you.

    Thx again to everyone

  21. Ok. It’s working fine in IE7 but maybe someof my visitors still use IE6 so if u can solve the problem and of course ur are not busy. Thx anyway ๐Ÿ˜‰

  22. Hello Bharath!

    This theme is really great! Congratulations! ๐Ÿ™‚

    I have the same module name problem in Firefox and IE 6 and 7 with the 22th Dec release =( how the way to fix?

    Sorry for my bad english, I’m chilean =P.

    Greetings!

  23. Thnx for the continous support Bharath!

    I have checked both Firefox 1.5 and 2, also IE 7, but Ajax commenting doesnt work on any of these browsers for me.

    I believe Ajax commenting is part of ur theme, i shudnt need any additional plugin for it, or shud i?

  24. This is a great theme. Though I have one problem: blog posts start with ‘published December 26, 2006’ or similar.
    I want the author name in front: ‘published by Carsten Pรถtter December 26, 2006’
    What has to be changed? Thanks a lot.

    Carsten

  25. Still can’t use it successfully. After downloading and choosing the new theme, i can’t edit any of the php files.

  26. Now the author name is displayed. Everything works like I want it to work. Very strange as I didn’t change anything. At least to my knowledge.

    So all the best for 2007 everyone.

    Carsten

  27. hi, i recently found your theme and upgraded my blog to 3 column!

    but in IE6 – as zuperman said – the sidebar is “going down” – there has to be something with the css driven column separation, ot you did not write some IE6 hack to make it display correctly.

    Since IE6 is still market leader (~has the biggest market share, its a shame) so its a big problem ๐Ÿ˜

    Im not a CSS guru so i dont think i could fix it, but if i succeed, i’ll tell you.

    Keep up the good work, its a great scheme!!

  28. Hi Bharath

    Firstly thank you for a great template. I have just installed it to kick off my new blog.
    I have a couple of questions. Firstly how did you get the divider lines between each section on the side bar?

    Secondly, the ‘About’ paragraph, how was that done, I notice each individual posting has a About Entry as well, is there a plug-in for this or is it done through the widgets?

    Thanks

    Virgil

  29. Hi and Happy New Year ๐Ÿ™‚

    I must say this is a great mod from K2, and I’m pretty pleased with it.

    However, K2 doesnt display the pictures from the latest post on the main index page…you need to click to “read more” in order to see any pictures.

    Is there a fix for it? Also, do you have plans to release a right and left sidebar version of this theme? I’m more towards a left right sidebar person ๐Ÿ™‚

    Anyways thanks and have a great 2007 !

  30. Are you planning to integrate a video Sidebar Module to the 3 column k2?

    Is there a way to use to asides in the same page?

    Great theme. great job!

  31. Hi Barath,

    thank you for the great theme. I have had some troubles with the sidebar modules (like everyone had in dec ’06) but it works now (or better: worked until today). I added a sidebar module and typed in a title with a german Umlaut (“Letzte Beitrรคge” translation: Last Entries). Result is that the modules disappeared again in the admin but are still visible on the site (http://www.segelwelt.de).
    I think it is the encoding of Umlaute like รค, รถ, รผ, รŸ and so which causes the problem.

    I looked in the directories on my server to find the place where the custom module information is saved to edit the file/header manually. But I did not find a file… Can you tell me where and how the custom sidebar modules are stored? Is it possible to change the Umlaut to a correct encoding manually?

    Thanks in advance for your help
    Best Regards
    /bahne

  32. Ahh. sorry… my configuration is:
    WordPress 2.0.5, K2 and 3 Column K2
    Current style is 3 Column K2 V 0.9.3 by Bharath Kumar

    Browser: Firefox 2.0

    Cheers!
    /bahne

  33. Hi. Just installed K2 0.9.3 , rendering in IE is perfect but in firefox, the header has display problems.
    I have put a 940×150 photo but the surrounding color which appears in IE 6.0.28 doesn’t in Firefox 2.0. The consequence is that the menu, except for “home” is not visible. I tried to put different values in “custom header options” without success.
    Any Idea ?
    I’m trying your theme and find it great because there’s a lot behind the scene utilities, so I want to keep up with. Please help .

    thanks

  34. Barath:

    I absolutely LOVE the theme. Starting a new blog right now, but there is a huge bug in the theme.

    In IE6 (I’ve heard IE7 too) the two sidebars appear BELOW all of the blog posts on the front page. There are no sidebars at the top, they are pushed all the way to the bottom. It’s happening on my site, it’s a topic on the K2 forums, and it’s happening on the front page of this very site when viewed in IE.

    (The thread on the K2 site is: http://getk2.com/forum/showthread.php?t=2921 . That’s one of about three so far.)

    Someone mentioned it might have something to do with an “SVN” that’s not updated (whatever that is). Love your theme, but unfortunately it’s not working in the most popular browser.

  35. After a lot of research it seems the K2 theme is what I’m looking for. Then there was only one thing missing: three columns. Now I found this site! Seems perfect!
    I’m about to install it right now.
    But I must say, the bug reports in the end here have me very worried.
    Hopefully I can return with a two thumbs up and not another bug report ๐Ÿ™‚

  36. I too am having the blank header problem.

    Bharath –

    Did I miss something? I don’t see where you responded to this issue. Is the header size important? Right now Im still using 955 x 200. The header and all of the links in it except the first are invisible. (Both on Firefox and Safari)

    Thanks very much
    Andrew

  37. Pingback: WordPress 2.1 at Matt Kelly

  38. sir your sidebar is going at the bottom when using Internet explorer 6, i have same problem with technoblue when i check it up in IE can you help me.

  39. Bharath –

    Allow me to answer my own question:

    I sorted out the no header image problem: Make sure the header image is 996 x 200, and small in size (

  40. Bharath –

    Allow me to answer my own question:

    I sorted out the no header image problem: Make sure the header image is 996 x 200, and small in size (less than 100k).

    I think it might be useful to post this info somewhere prominent. I had to do a search and then test it out to make sure it would do the trick.
    Thanks
    AJ

  41. I am wondering what or if all files changed between .9 and .9.3 as I have changed a lot of the files outside of the style sheet. The less I have to manually update again is the most ideal. Is there a list of what files specifically changed between versions?

  42. My header is not showing as well. I have a custom height but not width, so I am not making mine 995X200 but 995X140. What do I need to change to make it appear. It’s not in the style sheet. Is it in header?

  43. Love the theme but I’m having the whole “you must specify a valid module name” problem as well. And I’m fairly certain I’m using a valid name, i.e. Asides. Anyone know how to fix this?

  44. The header image size should be 995px width and 200px height.

    I will release a css file for IE6 issues. I dont have IE6 on my system as I am running vista for the last 2 months. But I will figure this out soon. If anyone have problems with IE6 pls post the screenshots of the problem.

    IE7 looks fine on my side. I dont see any breakups. I noticed one wierd thing which I will fix with the new update. If anyone have problems with IE7 pls post the screenshots of the problem.

    Yes, I am working on updating to the latest SVN right now. Will be released in abt an hour from now.

  45. Hi, i liked a lot your theme and I got it. I solved the IE 6 problem with this hack:

    In file style.css, line 70, .secondary: added
    float:right;

    In file switch.css, line 37, .secondary

    was : margin: 0 0 20px 545px !important;
    now: margin: 0 0 20px !important;

    I hope this works even for IE 7. In Firex 2.0 itโ€™s fine. Check it on my blog.

    Thanks a lot for your template ๐Ÿ™‚

  46. Jake: I updated this version for that problem. Please download it again ad try or wait for today, I am releasing a new update.

    The Reviewer: There is nothing much changes on my side. Most of them are in K2. You can check their SVN to see the changes.

  47. i’m having problem withe technoblue theme by JOHNTP,(johntp.com) in IE 7 its good, but IE 6 is problematic. I tried to contact John but he hasn’t replyied to my email(1 week has passed) The image link below.

    http://img264.imageshack.us/img264/4603/012120072057167ii.jpg

    On the IE status bar 2 errors coming,
    number 1 error
    LINE: 11
    char :2
    error: ‘undefined’ is nulled or an object.
    code: 0

    number 2 error

    LINE :539
    Char: 3
    Error: Object doesn’t support this property or method
    code : 0

    Maybe cos of this errors the side bars going down.
    Please answer as soon as possible.

  48. Ok Guys, I have just updated 3 Column K2 to the latest SVN release. But I havent released it yet. I want to check and clear all the wierdness before releasing it.

    So please check my blog in whatever browsers you are using and let me know how it looks. mainly IE6 users.

    Also try commenting and see how the ajax commenting working. It looks ok to me from FF 2.1.

    I will try to fix all the wierd things happening with this theme. So please everyone check it and let me know if you want me to change or fix anything.

    And please dont ask me for left and right sidebar version of this theme. I am not going to look into that for now.

    Pranjal: Can you check my blog in IE6 and let me know if u get same errors as in the screenshot you provided. Cos I am not sure which version you are using.

    Thanx to everyone who reported bugs so far. I will try to fix them all this week.

  49. Pranjal and aRmAn: Yep that looks pretty ugly. I had a brief chance to use my friends sys to check it. I am still figuring it out and will make it work in IE6.

    If you find anything else other than the sidebar problems in IE6, please let me know. Thx both of you.

  50. Cool! Just checked this site in IE6 and it’s working great! Can’t wait ’til it’s released!

  51. Its working fine now. Bharat can i ask you a question. How did you manage to make it good in IE6. I’m using TechnoBlue theme (http://wwww.johntp.com) its showing up the same problem (that sidebar ISSUE) can you check out my site and help me. I’m a noobie when it comes to CSS.

  52. Ok, I am still not happy with this but I am looking in to it. I will release it once I feel comfortable and all other things are sorted out. Anyone had problems with Ajax Commenting ? Please let me know.

  53. Hi! Kumar,

    I need the 3 column k2 0.9.1. Where can I download it? thanks.

    I need it due to plugins issues.

  54. Thanks again.

    I have been using your style for about 8 months. I just upgraded to 0.9.3 and I seem to have lost my K2 Modules somewhere along the way. Do you know what might have happened to them.

    Now I only have the K2 Widgets… and the site does not look like I want it to look.

  55. Hi Mr. Kumar,

    please post the status of the update. many are waiting for the release. ๐Ÿ™‚

  56. Hello Bharath!
    You have hot theme, man!
    Instead of asking for “more …” let me ask How I can help you?

    Just let me know what I can do to help you with this stuff – I’m not programmer but sure can be useful for you, buddy!

    Drop a line here in comments or by mail.

    I’ll be honored to help you;)

  57. Bharath –

    I upgraded to 2.1 (without seeing your warning first, and now am getting this error when I click any of my individual by-category archives:

    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘GROUP BY year(post_date), month(post_date), dayofmonth(post_dat]
    SELECT DISTINCT post_date FROM wp_posts LEFT JOIN wp_post2cat ON (wp_posts.ID = wp_post2cat.post_id) LEFT JOIN wp_categories ON (wp_post2cat.category_id = wp_categories.cat_ID) WHERE 1=1 AND category_id IN (4) AND (post_type = ‘post’ AND (post_status = ‘publish’ OR post_status = ‘private’)) GROUP BY wp_posts.ID GROUP BY year(post_date), month(post_date), dayofmonth(post_date)

    I hope this is of some use to you as you prepare the update.

    Thanks for the great theme,
    Andrew

  58. I’m getting the same error as Andrew but mine comes and goes, i.e. when viewed in IE its not there but sometimes it’s there on firefox. Looking forward to the upgrade Bharath, you’ve done awesome work so far.

  59. Bharath –

    It looks like you have updated the theme for 2.1, since you changed the header tag from “Hang on before updating”. I tried installing the new version to my WP 2.1 setu, but get a variety of errors, such as:

    Fatal error: Call to undefined function: is_active_module() in /home/dikarro/public_html/blog/wp-content/themes/3ColumnK2-0.9.5-RC1/app/includes/info.php on line 186

    I tried disabling all plugins, but it made no difference.

    Do you have any thoughts on what this means? Is there some special way we should perform the upgrade?

    Thanks
    Andrew

  60. A little more info: that error come up after clicking “view site”, as well as clicking several links under the “Manage” tab.

    AJ

  61. Pingback: Umzug komplett at MEin Blog(versuch)

  62. Pingback: Looking for a New Wordpress Theme? at Not So Relevant

  63. Pingback: links for 2007-02-18 at DeStructUred Blog

  64. Pingback: Lavado de cara… | Isopixel

  65. Pingback: Blog de descargas, antivirus, programas, software, musica, pelรญculas, novedades y mas ! » Blog Archive » Lavado de caraโ€ฆ